Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 13, 2024 - 09:30 EET
Scheduled
Scheduled maintenance is planned to enhance our infrastructure. All services will remain fully operational, and we do not anticipate any downtime or disruptions.
Posted Nov 12, 2024 - 21:40 EET
This scheduled maintenance affected: Payments API, Data API, and Merchants Portal.